Unverified Commit 4da627a3 authored by Tanguy Le Carrour's avatar Tanguy Le Carrour Committed by Marius Bakke

gnu: python-slugify: Update to 4.0.1.

* gnu/packages/patches/python-slugify-depend-on-unidecode.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/python-web.scm (python-slugify): Update to 4.0.1. [source] Drop patch.
Signed-off-by: default avatarMarius Bakke <marius@gnu.org>
parent 4fae4f9a
......@@ -1468,7 +1468,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-pygpgme-fix-pinentry-tests.patch \
%D%/packages/patches/python-robotframework-honor-source-date-epoch.patch \
%D%/packages/patches/python-shouldbe-0.1.2-cpy3.8.patch \
%D%/packages/patches/python-slugify-depend-on-unidecode.patch \
%D%/packages/patches/python2-subprocess32-disable-input-test.patch \
%D%/packages/patches/python-tinycss2-flake8-compat.patch \
%D%/packages/patches/python-unittest2-python3-compat.patch \
......
diff --git a/setup.py b/setup.py
index 4800173..6bdd77f 100755
--- a/setup.py
+++ b/setup.py
@@ -14,8 +14,7 @@ url = 'https://github.com/un33k/python-slugify'
author = 'Val Neekman'
author_email = 'info@neekware.com'
license = 'MIT'
-install_requires = ['text-unidecode>=1.3']
-extras_require = {'unidecode': ['Unidecode>=1.1.1']}
+install_requires = ['Unidecode']
classifiers = [
'Development Status :: 5 - Production/Stable',
@@ -67,7 +66,6 @@ setup(
author_email=author_email,
packages=find_packages(exclude=EXCLUDE_FROM_PACKAGES),
install_requires=install_requires,
- extras_require=extras_require,
classifiers=classifiers,
entry_points={'console_scripts': ['slugify=slugify.slugify:main']},
)
......@@ -3522,15 +3522,13 @@ Python.")
(define-public python-slugify
(package
(name "python-slugify")
(version "3.0.4")
(version "4.0.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "python-slugify" version))
(sha256
(base32 "0dv97yi5fq074q5qyqbin09pmi8ixg36caf5nkpw2bqkd8jh6pap"))
(patches
(search-patches "python-slugify-depend-on-unidecode.patch"))))
(base32 "0w22fapghmzk3xdasc4dn7h8sl58l08d1h5zbf72dh80drv1g9b9"))))
(native-inputs
`(("python-wheel" ,python-wheel)))
(propagated-inputs
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment